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[bookmark: _Toc31989474][bookmark: _Toc31835202]Rack Loadout Reports
1. In VSD, Open a project
2. Open a script.  This turns on the Script Reports[image: ]
3. Open the Script Reports and press the "Racks" button[image: ]
4. [image: ]This takes a copy of the Script you have open and copies it to a new DB with the same name, but with the ".rld" extension.  This is the RackLoadout database.  This is now opened up and placed in a grid sorted by position and caliber.  Rackable words are applied to each cue to determine if it is a rackable cue.  Then if a Rack Info database is open it is applied to the cues.  The match is made using several criteria listed in "Rack Loadout: How Cues are matched up to Racks".  If a matching rack with empty tubes is found, the rack name is place in the Rack Name column of the cue.  If no match can be found for a rackable cue the word "<<NOMATCH>>" is placed in the Rack Name and it is highlighted Red.  If a match is found, but all instances of that rack are full, the rack name will be set, but no Rack Instance will be set and it is highlighted Yellow. 
5. The rackable match words can be edited from the menus using Edit->Edit Rack Match... [image: ]
6. This brings up the Rack Matching Types dialog[image: ]
7. Add/Edit/Delete words from these two lists.  The two lists are applied as follows:
· Words from the Non-Rackable Types are looked for in the TYPES and Effects Description columns of each cue.  If any of these words are found in either of these columns that cue is marked as NOT RACKABLE
· Words from the Rackable Types are then looked for in the TYPES and Effects Description columns of each cue.  If any of these words are found that cue is marked as RACKABLE.
8. This list is saved in the AppData folder in a .ini like file and are reused for each project.  There are only one set of rackable type words.
9. Now it is time to add a rack database to our project.  Do this by using the menu Edit->Edit Rack Info DB...
10. This brings up the Edit Rack Info dialog[image: ]
11. At first it will be empty and you will need to enter the information for each of the rack types you have.  
· The NAME must be unique and is used to identify each type of rack you have.  
· MFG and REF are open fields.  
· CAL must be a single caliber number, a caliber list or a caliber range.  If this rack can take a specific list of calibers, they are listed separated by a '-'.  For example if it can take specifically 10, 20 and 30 caliber tubes, we put "10-20-30".  If the rack can take any caliber in a range, the start and stop caliber are separated by a '*'. So for a range between 10 and 30 we put "10*30".
· ANGLES must be a single angle number, an angle list or an angle range.  If this is a fan or angled type rack with a list of specific angles, the angles must be separated by a '-'.  If this is a rack in which any angle can be placed within a range the start and stop value are separated by a '*'.
· PICTURE is an open field and should be used to make a small pictogram that represents the angles in the rack.  
· TUBES is the number of tubes in each row of the rack.  If the ANGLES specifies a list, the TUBES value should match that list.  For example "30-45-90" should have 3 TUBES.  If the ANGLES are a single value or a value range, TUBES tells us how many TUBES will be in each ROW.  
· ROW is the number of rows of tubes.  TUBES x ROWS = total number of product that can be put in this rack.
· MAGAZINE is the number of rack of this type you have in your inventory.  So a given RACK NAME can have MAGAZINE number of instances to be place in positions. 
· MATERIAL,SIZE and WEIGHT are open fields that you can use to store relevant data to this rack. 
· RESERVE column specifies that the type or rack is reserved for only exact name matching using the ANGLES column.  See Appendix A on how matching is applied.
· AVAILABLE column is a YES or NO value stating if this rack type is available for use by this show.  The idea here is that you can exclude whole types of inventory for a show without having to edit the MAGAZINE value to zero.  
Pressing the DONE button will save your database.  The Open button will let you open another Rack inventory database.  In this way you can have several independent databases, but you can only use one at a time.

12. Your grid can be printed out (same as any of the grids in VSD) using the menu Print->Print Rack Loadout. [image: ]
13. Now that you have all of your cues and racked matched up, it is time to Export  this to a Rack Loadout Report.  Do this using the menu File->Export Rack Loadout (.xls). [image: ]
14. [image: ]This will generate a .xls file that has been sorted by POS, CAL and RACK NAME and tallies up the QTY from each cue of this type.  Note that if you have a rack with multiple instances in MAGAZINE, the INST column will have which instance this cue is in
15. [image: ]Any given rack instance can only be in one POS so in this example for POS1, this is one cue in one tube and that is all that will be put in this rack.   Below is a fuller example for POS2
16. White are rackable cues that are in a rack
17. Gray are non-rackable cues
18. Yellow are rackable cues for which a matching rack was found, but there were no empty tubes available.
19. Red are rackable cues for which no matching rack could be found
20. Total Qty is 'how full is this rack'.  We visually indicate how full it is by color from Red (0% full) to Green (100% full).  This makes for a quick way to see how optimally the racks have been used.
[bookmark: _Rack_Loadout:_How][bookmark: _Toc31989475]Rack Loadout: How Cues are matched up to Racks

After a cue has been determined to be rackable, a series of matching rules are applied to try to place this cue into a rack.  As mentioned earlier, for a cue to be rackable it must have a POS value, it must have a CAL value and it must have some correct value in either ANGLE or TILT.
The restrictions for the cue ANGLE or TILT values are as follows:
1. If ANGLE is non-blank, then it is used.  Otherwise the value in TILT is used.
2. The value of ANGLE can specify a rack name and that will be the priority when placing this cue.  However, if all instances of the rack specified are full, then regular rules for rack matching are applied
3. The value of ANGLE (or TILT) can be a single angle such as "90"
4. The value of ANGLE (or TILT) can be hyphen separated such as "45-90-135" for a fan.  For this cue to be placed into a rack, that rack must have a row with at least 45-90-135 angles based on an exact match or wildcard usage.
5. In all cases, the QTY column must accurately reflect how much product (and therefore how many tubes) are required.  For example in the above fan, then QTY would be 3.
When rack matching starts, we sort the script by POS value.  This groups the cues by the POS they are at.  We then take each cue at that position and try to find a matching rack.  If a match is found and that rack is empty it is assigned to that POS.  A rack can only be in one POS, so if a different POS also needs this type of rack, it will require a new instance of this rack.  The Rack Info DB MAGAZINE value tells us how many instances of this rack we have to spread around the different positions.
The values of the cue CAL and ANGLE (or TILT) are looked at during this matching process.  We try several times to find the best match between the cue and the racks.  For each of the 'best match' comparisons we look at every rack in our inventory.  Racks are ignored for several reasons like it has been made unavailable, it is RESERVE, it is already in a POS that is not ours or they are already full.  We start with the most strict matching criteria and keep loosening the criteria until we have a match or can't find any rack in inventory that will do.  If we find at least one rack in inventory that would have worked, but was not available to us, we mark that cue with that rack name but leave the Instance blank.  This way you know what we felt was the best match so you may add to the Rack Info DB MAGAZINE value.  If we were unable to find any racks that match our cue CAL and ANGLE we mark that cue with <<NOMATCH>> rack name.
The order of the match criteria is:
1. The cue's ANGLE column has a RackName in it.  If we have a rack who's name exactly matches the name in the ANGLE column we just use it if it is available and not full.  If we can't find the name or all instances of that rack are unavailable we continue.  The Rack Info DB has a column called RESERVE that if set to YES, reserves this rack type for only exact name matches.  If the RESERVE is set to NO, then it will also be used by CAL/ANGLE matching.
2. We look for an exact match of the CAL and ANGLE values to the rack CAL and ANGLES values.  So for example of CAL was "30" and ANGLE was "90" we must find a rack that has CAL and ANGLES of "30" and "90" respectively.  If the CAL is "20" and the ANGLE is "15-30-45" we must have a rack with the CAL of "30" and the exact ANGLES of "15-30-45".  If no exact match is found we continue.
3. We look for a wildcard match of CAL and an exact match of ANGLE.  This would be a rack who's CAL value is a list (like "20-40-60") or a range (like "20*60").  If our CAL matches one of the values in the list or falls within the specified range we check ANGLE for an exact match. If no match is found we continue.
4. We look for an exact match of CAL and a wildcard match of ANGLE.  This would be a rack who's CAL value is exactly a match, but the ANGLE value finds a wild card match.  So for example if the with a cue CAL of "20" and an ANGLE of "45" if we find a rack with CAL of "20" and ANGLES of "30-45-90" it would match as there is a "45" spot in the row of angles.  We would also match on a rack with a CAL of "20" and ANGLES of "10*80" as 45 falls within the range of 10 to 80 degrees. If no match is found we continue.
5. Finally we look for a wildcard match of CAL and a wildcard match of ANGLES.  This is as wide open of a match as we can make looking for any possible rack to put this cue into.
Once a matching rack is found, we check to see if there are enough tubes available in this rack based on the cues QTY value.  If there are, we use this rack.  If not, we continue either finding another instance of this rack or looking for another rack type that matches.
Let's take a look at a very simple Script and a limited Rack Info DB and see how matching would work.
Our Rack Info DB:
[image: ]
Our Script in the Rack Loadout form:
[image: ]
1. This cue is not RACKABLE (based on our Rack Match word lists) so no rack was assigned.
2. Here the CAL is "20" and the ANGLE is "90" and that is an exact match of the rack named "rack3"
3. Here we have CAL of both "50" and "20" with a mix of ANGLES of "90" and "60-90-120" (from TILT).  The first cue of this set went to "rack6" because of the wildcard for CAL.  Then the next cue goes to "rack6" rather than the exact match in "rack3" because we have changed POS and we only had one "rack3" (now in POS1).  The next best match that has an instance available is "rack6".  We also matched a CAL of "20" and ANGLE of 60-90-120 to the wildcard in both CAL and ANGLES that "rack6" has.
4. When we change POS, we have to leave behind any racks assigned there, even if there were available spots.
5. The rack name "rack4" was giving for this cue and that is the rack given (see #7)
6. These cues are rackable, but due to the "45" angle we can't put them into any rack.  Notice that our Rack Info DB doesn't include any racks with an ANGLES of 45 or a list or range including 45.
7. Here we have tried to assign this cue to "rack4", but we don't have any available instance of "rack4" to put into this POS.
So looking at  our Rack Info DB and the Rack Loadout script we can see how the rules for matching get applied.

[bookmark: _Toc31835210][bookmark: _Toc31989476]Updates to WAV Window
[bookmark: _Toc31835211][bookmark: _Toc31989477]Move Left and Right using  SCROLL
With the WAV window selected, scroll the Mouse Wheel to scroll the wave display left or right.
[image: ]
[bookmark: _Toc31835212][bookmark: _Toc31989478]Zoom Using SCROLL
With the WAV window selected, Shift+Mouse Wheel to zoom in or out from the selected mark.
[image: ]
[bookmark: _Toc31835213][bookmark: _Toc31989479]Copying and Moving Cues on the Wav 
This new tool allows you to move and copy Cues in the audio line in a very fast way.
Select the cues you want to move or copy. You can select multiple cues by clicking the first and last cue with the SHIFT key.
CTRL + Click on the audio line where you want to move or copy the Cues 
Select whether you want to move or copy the Cues
[image: ]
[bookmark: _Selección_Múltiple_de][bookmark: _Toc31835214][bookmark: _Toc31989480][bookmark: _Multi_select_of]Multiple Filters Selected for Effect Manager.
This tool allows you to select multiple EFFECT FILTER MANAGER filters and apply them to our EFFECT MANAGER.
1) Select the filters you want to apply, you can add multiple filters in 2 ways.
a. Continuous selection: Click on the row of the first filter after pressing SHIFT click the last row of the filter applied.
[image: ]
b. Non-continuous selection: Select the filters you want to apply by holding down the CTRL key
[image: ]
2) Apply filters by right clicking on the EFFECT FILTER MANAGER
[image: ]Example:



[bookmark: _Toc31835215][bookmark: _Toc31989481]Auto Filter Creation
After performing a filter with multiple selections (See Multiple Selection Filters in Effect Manager), we can create a new filter that contains all selected filters.
1) We perform the filter with multiple selections (See Multiple Selection Filters Filter Effect Manager) 
2) We double click on the last row of the EFFECT FILTER MANAGER
3) A message will appear if we want to create a new filter based on the previously selected, we click on Yes 
4) The filter is created with the name Quickfilter
5) [image: ]Rename the filter.




[bookmark: _Toc31835216][bookmark: _Toc31989482][image: ]







Filter Find / Replace
This function allows you to filter the results of searches of the "Find / Replace" tool
1) Click where you want to search and filter
2)  Click on the icon Find / Replace tool or press SHIFT + F3
3) The main window appears
4)  Enter what you want to search 
5) Click on Find 
6) Click Filter to filter by the cell our found
[image: ]



[bookmark: _Toc31989483]Setting PFT Time Format
You can select the format of the PFT column.  
Click on the Script and press F11, or right click with the mouse over the PFT column header. 
Select Time formats.
PFT in 1/10 of a Second is writen with decimal. Example 8.5=8 and 1/2 second.
PFT in Miliseconds is writen from 0000 to 9999
[image: ]
[bookmark: _Toc31835218]











[bookmark: _Toc31989484]

Cross Filters
This option can set filters in the Script Manager from a selection in the Effects Manager or in the Effect Manager from a selection in the Script Manager.
In either the Script Manager or the Effect Manager, click on a cell in a column common to both.
Press the 'Cross Filter' icon [image: ]
In the example below, the REF value in the Effect Manager is used to create a filter in the Script Manager
[image: ]
[bookmark: _Toc31835219]
[bookmark: _Toc31989485]

Create PAN & TILT Fans [image: ]
This tool lets you create auto fans in Pan and Tilt. 
Select the cues you want to add fan
Click on the menu Cues or Icon in the Cues Toolbar.
Select the Fan Tool 
Sets the values ​​of Start and End
[image: ][image: ]Click Create Fan 

[bookmark: _Toc31989486]

Auto Group Positions
Scripted POSITIONS can be added to a common GROUP.  This makes filtering or sorting easier once you have many positions in your show.
1) With your show loaded, bring up the Cues > Group Positions dialog
2) Create a new Group Name or enter an existing Group Name to add additional positions
3) Multi-select from the list of Positions those POSITIONS you would like added to the Group
4) Press Apply and all cues with the selected Position will have the GROUP column updated to the new Group Name.  You can delete the names from the GROUP column at anytime and rerun this to reassign names.


[image: ]


[bookmark: _Toc31989487][bookmark: _Toc31835220]Pyromac Script
[bookmark: _Pyromac_Adressing][bookmark: _Pyromac_Direccionamiento][bookmark: _Toc31835203][bookmark: _Toc31989488]Addressing Pyromac
Pyromac system was added to export to both Automatic and Macro mode including DMX commands.
Download the the "PYROMAC Layout"
VSD 8.4.5 (1/21/2021)	Page 24

Click on the script and press F11
Select Script option in the Grids section
Click Load
Select the Layout "PYROMAC"
Click Done

[image: ED86A2E.tmp]

Address the show

Press F4 to address
Set the parameters for MOD and PIN as shown
Click on Renumber 


[image: ED8638D.tmp]
Press F8 to update the script before exporting
Exports show for Pyromac shooting system
Click on the menu File > Script File > Export...
Assign a name to your script 
Selected Type: Pyromac Script File (* .txt)
Click Save
You will be prompted on which type of show you have:  Pyromusical or Macros.
[image: ED8D858.tmp]


[bookmark: _Toc31835204][bookmark: _Toc31989489]Macro function
The MACRO function is useful for scheduling different semi-automatic sequences where the first shot is manual and continuous sequence of shots.
To add macros 
Layout for Pyromac loaded (see Addressing Pyromac - Step 1)
Macro column groups the sequences with the same number
[bookmark: _GoBack][image: ]
Export show to the firing system (see Addressing Pyromac - Step 4)
Remember to click No to export as Manual Macros
[image: ] 


[bookmark: _Toc31835205][bookmark: _Toc31989490]DMX programming for Pyromac
Program any DMX device and export to your Pyromac firing system
Load Layout "PYROMAC DMX" (See step 1 Addressing Pyromac)
We will use columns CUSTOM1 to CUSTOM8. In them you can add the channel values, look at the following examples:
[image: ED89E5.tmp] [image: ED89E5.tmp][image: ED89E5.tmp] [image: ED89E5.tmp]
To program a DMX device requires the following columns:
Event Description: Device name
DUR: Duration of the effect. 
MODULE: Channel DMX Device must begin with the number 900. 
PIN or CUSTOM columns	
DMX cues use the PIN column OR the CUSTOM columns.  Usage is determined by:
· Only CUSTOM columns that are Visible are used.  Hidden columns are ignored so you don't generate data you can't see
· If there are any CUSTOM columns with numerical data (non-alpha) than only the CUSTOM columns are used.  PIN is ignored
· If there are no CUSTOM columns visible or with numerical data, the PIN column is used
· If CUSTOM columns are used, The CUSTOM column index is added to the MODULE value.  So if CUSTOM1 is used, the data is placed on the channel in MODULE.  If CUSTOM2 is used, the channel is MODULE + 1.  If CUSTOM3 is used, the channel is MODULE + 2, etc.  There can be up to 8 channels written per script cue if all eight CUSTOM columns contain valid data.
· Data in the PIN and CUSTOM columns are range capped to 0-255.  Values below 0 are 0, values over 255 are 255

NOTE: If you are getting "Out of range" errors, go to the Cue > Renumber Address dialog and change the min and max Module and Pin to reflect the range of values that you may be using.  Just set the Min and Max values and then press 'Done', you don't need to renumber the addresses.  This will adjust the range checking and stop out-of-range rejections.
	
[bookmark: _Toc31989491]Import Finale 2D Script
This option allows you to import scripts and modify Finale 2D in VSD
In Finale 2D click on the File menu
Click on Export CSV show as Generic File
Click on ASCII encoding
Click on Export
Click on Skip Music
Assign a name and save it.
[image: ]





After exporting the Finale 2D Script, we continue to import into Visual Show Manager.
Click on the File menu
Click Script File
Click on Import...
Select Finale 2D Script File as the type of script you want to import. 
Select the file you exported from Finale 2D and press Open
Create a new name for the import to be saved to and press Open

[image: ]



[bookmark: _Toc31835221][bookmark: _Toc31989492]Customize Effect Manager and Script Manager Reports
Users can customize reports for the Effects Manager or Script Manager. Included in version 8.4 without SD Tools authorization.
1) Click on the menu Reports
2) Click on the Effects...
[image: ]

Effect Reports appears with a variety of preset reports and a section where we can create customized reports.
[image: ]
Custom reports are created by customizing the columns, filters, and sorts in the Effect Manager and then keeping them together. These reports will be available in all projects to any Script.
Customizing the interface is as follows Reports
a) Default is a list box where you can edit existing reports show or enter the name of one to Add. The first report called 'Default' is the order of the columns in your script when loaded. Be careful not to overwrite after loading, printed or saved a custom report, use 'Default' to return the script back to its initial state.  Do delete a custom report, select it in the list and press the DELETE key.
b) Load: take the report and applies the selected column hide / show, filter and sort the current script depending on how the report was customized.
c) Print: displays the Print Preview. This button is dimmed if your system has no configured printer.
d) Add: add the report to your set of custom reports. If the name already exists, it overwrites this set with the new data.
e) Save: saves the selected report in an Excel spreadsheet.
[image: ]




[image: ]

[bookmark: _Toc31835222][bookmark: _Toc31989493]Merge Effects Manager
This will combine a file with the current Effect Manager that is loaded. It will add references not found in the current Manager.
[image: ]
Matching references will be overwritten, however, you may choose not to overwrite some columns. 
Only the columns that are selected will be overwritten. 
[image: ]
There is also a Merge option that will find effect in your current Effect Manager that are not in the merging Effect Manager and remove them.  This feature is so that you can merge into your current manager only those columns you have selected and still remove non-overlapping effects.


[bookmark: _Toc31835223][bookmark: _Toc31989494]Other Improvements:
1. Change serial numbers to only be VSD Online. Every product will use the same serial number.
2. When you click on the wav, you always do not scroll down in the script to display the cue Highlighted (Done)
3. Fixed issue with Open New Script Filter file
4. Fixed issue putting single quote in REF field causing crash 
5. Fixed issue with auto-complete of numbers adding "000000000" to each number 
6. Fixed issue with Cue Insert add POS of just incrementing ADDS numbers "0000000000" to each number
7. Fixed issue with Cue Insert add POS of alpha positions incrementing / decrementing does not work
8. Made the MAGAZINE column sort numerically
9. Added save safe for FXGen "Save Effects Library" to deal with random crashing wiping out the effects library you have open.
10. FXGen and VSDCreator log files moved to DebugLogs log files folder in AppData
11. Fixed issue with a newly created Script Filter has CUE2 as '10'





[bookmark: _Toc31835224][bookmark: _Toc31989495]Download Links:

[bookmark: _PYROMAC_Layout][bookmark: _Toc31835225][bookmark: _Toc31989496]PYROMAC Layout
https://www.dropbox.com/s/318qhzgp9ccrbzq/PYROMAC.scxl?dl=0

[bookmark: _PYROMAC_DMX_Layout][bookmark: _Toc31835226][bookmark: _Toc31989497]PYROMAC DMX Layout
https://www.dropbox.com/s/7l5j46m959vajzo/PYROMAC%20DMX.scxl?dl=0
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Personalizar Vista de Reportes de Effects Manager
De igual manera como podemos personalizar los reportes de los scripts podemos personalizar los
reportes de nuestros Effects Manager.

1) Clicken el Menu de Reports

2)

Effect Mgy Merge : If there are references found in your loaded Effects Manager that are not in the
merging Effects Manager, we will delete the reference from the merged resylt,e should also say
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This wil merge an Effect Manages e into the curent Effect Manager you have loaded. References not found in the curent
manager wil be added. Matching eferences willbe over-witen, however you may choose not o over e some columns. Only
the columns that are sslected wil be aver-wien.

Effect Manager Columns
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¥ EFFDESC 7 PRICE 3 [ CUSTOM 5
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